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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

* Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

° On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign > Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter’ means to

press the key labeled Enter.
« |talic type is used for the following:

° Emphasis.

° The titles of publications.

o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

* The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key

or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

« The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

@ AL
O .
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

* The menu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the File menu, click the Open Examples command" means you can click the File
menu and then click Open Examples to launch the dialog box.

* Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu
To access help from the Help menu, click Help and select from the menu:
* [product name] Help - opens the contents of the help. This help includes the help for the
product and its Getting Started Guides.
* [product name] Scripting Help - opens the contents of the Scripting Guide.

« [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Multi-Frequency Adaptive Meshing

This document looks at the different adaptive meshing schemes in HFSS for simulating elec-
tromagnetic devices. Multi-frequency adaption, which allows you to perform mesh adaption at
more than one frequency is compared with single frequency adaptive meshing. Finally,
examples are shown and results from the different mesh adaption schemes are compared.

Adaptive Mesh Refinement

Automatic adaptive meshing in HFSS is an essential and integral part of the simulation process.
An appropriate mesh that supports electromagnetic calculations is essential to obtain accurate
results. In HFSS, meshes representing the design and its electromagnetic characteristics are
produced automatically ensuring efficient simulations in generating accurate results.

HFSS has always supported single frequency adaptive meshing. In this method, HFSS starts
with an initial mesh, determines the mesh induced solution errors at a single frequency, and then
refines the mesh at locations with the highest error. This process continues until the con-
vergence criteria is satisfied and the solution converges.

The adaptive mesh refinement process is enhanced by the multi-frequency adaptive meshing
feature, which generates solutions at several frequencies and combines the mesh induced solu-
tion errors across these frequencies to determine locations where further mesh refinement
occurs. This iterative adaptive refinement continues until the solution converges. This ability to
adapt the mesh at multiple frequencies yields more accurate solutions across a broad frequency
range.

Concept of Single Frequency Adaptive Meshing

In HFSS, the single frequency adaptive meshing is a time-tested method for simulating elec-
tromagnetic structures and generating accurate solutions. In this method, HFSS starts with a
coarse initial mesh. This mesh is solved to produce an error for each element in the mesh. The
errors are used to determine how to refine the initial mesh and produce a mesh, better suited for
physics simulation such as computational electromagnetics using FEM. Although we refer to
mesh refinement, the process also includes modification to element size and the order of the
basis functions used in the numerical method. Using the refined mesh, the solver is again
invoked to produce a new set of errors for further mesh refinement. This iterative process con-
tinues until the mesh is deemed to be converged by monitoring the change of some critical para-
meter, such as S-parameters, between consecutive meshes. The following figure demonstrates
the single frequency adaptive mesh refinement process flow. Optional seed refinement is
included before the adaptive process starts for a more suitable starting mesh.

Multi-Frequency Adaptive Meshing 1-1
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Single Frequency Adaptive Mesh Refinement Flow Chart

Concept of Multi-Frequency Adaptive Meshing

The multi-frequency adaptive meshing method, implemented in Ansys HFSS, provides you with
an efficient and convenient method to automatically obtain a mesh appropriate for broadband fre-
quency simulation where the adaptive algorithm uses errors from multiple time-harmonic fre-
quency simulations when refining the mesh instead of using only one frequency. Note that for
each adaptive pass, the same mesh is used for all frequencies in order to generate errors for
mesh refinement for the next adaptive pass. This process is described by the flow chart in the

Multi-Frequency Adaptive Meshing 1-2
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following figure. At a high level, the differences compared with single frequency adaption include
generation of errors from multiple frequencies at each adaptive pass and combining of the errors
before refining the mesh.

Multi-Frequency Adaptive
Mesh Refinement Flow Chart

No
\/

There already exist adaptive techniques to tailor a mesh for broadband frequency analysis.
Those techniques amount to adapting a mesh at N frequencies sequentially via mesh links in

Multi-Frequency Adaptive Meshing 1-3
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HFSS. If the ordered frequencies are f1, f2,...,fN the adaptive refinement process starts with fias
the first frequency using a coarse initial mesh. The process then follows the steps shown in the
Single Frequency Adaptive Mesh Refinement Flow Chart until convergence. Next frequency f2 is
solved using the converged mesh from f1, as the initial mesh and once again the steps shown in
the Single Frequency Adaptive Mesh Refinement Flow Chart are applied by the adaptive pro-
cess. This process continues until the convergence of the final frequency fN. The ability for all
adapt frequencies to influence mesh adaption at each pass is a major benefit of using the new
multi-frequency adaptive meshing algorithm in HFSS compared to the sequential multi-fre-
quency adaptive meshing approach. It typically produces a smaller final mesh and improves the
adaption performance by solving the frequencies in parallel.

The multiple-frequency adapt algorithm has three potential performance benefits compared with
the standard sequential algorithm. The benefits are as follows:

» Solves adapt frequencies in parallel.

+ Reuses the solutions of all the adapt frequencies for subsequent frequency sweeps. In
contrast the sequential method can reliably reuse only the solution of the last frequency
since it solves other frequencies on different meshes.

« Obtains a smaller mesh that yields similar accuracy.

Solution Frequency Setups

There are three types of Solution Frequency setups in HFSS. These setups enable adaptive
meshing to occur at either single or many different frequencies. The Multi-Frequencies and
Broadband Solution Frequency setups provide you with two different options of adapting the
mesh at various frequencies for your design. Based on the solution frequency setup and the spe-
cified convergence criteria, HFSS automatically creates a suitable mesh for your design and gen-
erates accurate solutions. Once the final mesh is generated, HFSS also creates a solution
across a frequency range of interest provided you defined a frequency sweep.

The difference in the S-parameter value between two consecutive adaptive passes is known as
Maximum Delta S. The most common convergence criterion is determined by the value of Max-
imum Delta S, which should be less than the specified magnitude. For example, in the following
figure the specified value of Maximum Delta S is 0.01. Once Maximum Delta S goes below this
value or if the Maximum Number of Passes is reached (whichever happens first ) the sim-
ulation converges.

Adaptive Solutions

Solution Frequency: {* Single " Multi-Frequendes " Broadband
Frequency | 5 GHz ﬂ
Maximum Mumber of Passes | 10

(' Maximum Delta 5 |0.01

Multi-Frequency Adaptive Meshing 1-4
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The subsequent sections describe each of these Solution Frequency setups.
Single Frequency

For the single frequency setup, HFSS adapts the mesh at that specified frequency for your
design until the convergence criteria is satisfied. Once the solution converges, the final mesh is
used to predict the electromagnetic characteristics of the design. The solution is also generated
across a range of frequencies, if a frequency sweep is defined.

Broadband and Multi-Frequencies Solution Frequency Setups

In most cases, the Single solution frequency is sufficient to generate accurate results. For broad-
band devices if you want increased reliability and more accurate solutions, use the Broadband
Solution Frequency setup. This feature is especially useful when you are uncertain about choos-
ing the best frequencies for adapting the mesh. Broadband meshing eliminates this uncertainty
by automatically determining the appropriate frequencies at which to adapt the mesh based on
the user-entered range. Broadband will use at least three adapt frequencies and in order for addi-
tional frequencies to be used, you need to enable high performance computing (HPC) and have
available hardware such that all adapt frequencies can be solved in parallel.

The interpolation sweep is predefined by a frequency range identical to the Broadband. In addi-
tion, the algorithm chooses the adapt frequencies in a way that they will likely be reused in the
frequency sweep. If you know a priori the frequencies at which to adapt the mesh for your
design, you can specify the Multi-Frequencies Solution setup. Adaptive meshing occurs at all
the frequencies that you define in this setup.

Broadband Adapt For Conical Sinuous Spiral Antenna

The figures below shows a conical sinuous spiral antenna design in HFSS.

Multi-Frequency Adaptive Meshing 1-5
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Side view

I top view |
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Perfect E boundary conditions are assigned on the four arms of the antenna and the feed metal.

Multi-Frequency Adaptive Meshing 1-7
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The antenna is excited with a lumped port.

The Broadband Frequency Analysis Setup definitions are as follows:

* Broadband Frequency Range =2 GHz to 15 GHz.
* Aninterpolating S-parameter frequency sweep ranges from 2 GHz to 15 GHz.
» Auto HPC is defined and 12 cores are used for the simulation.

Multi-Frequency Adaptive Meshing 1-8
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Driven Soclution Setup ﬁ
General lOptinns ] Advanced ] Hybrid ] Expression Cache ] Derivatives ] Defaults ]
Setup Name |Bn:uau:||:uanu:|
[v¥ Enabled [ Solve Parts Only
Adaptive Solutions
Solution Frequency: " Single " MultiFrequendes {* Broadband
Low Freguency | 2 |GH2 j
High Frequency | 15 |GH2 ﬂ
Maximurn Murnber of Passes | 25
Maximum Delta 5 | 0.02
Ilze Defaults |
HPC and Analysis Options... ‘
ok | cancal |

The return loss after running the broadband solution frequency setup simulation is shown in the
following figure.

Multi-Frequency Adaptive Meshing 1-9
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Multi-Frequency Setup For Conical Sinuous Spiral
Antenna

For the same design of the conical sinuous spiral antenna you can define a multi-frequency

o b e s ww wm um

1200

setup provided you know a priori at what frequencies you want to adapt the mesh. In particular,

this antenna was designed to work at 4 GHz and 10 GHz.
The Multi-Frequencies Analysis Setup definitions are as follows:

¢ Multi-Frequencies =4 GHz and 10 GHz.
* Aninterpolating S-parameter frequency sweep ranges from 2 GHz to 15 GHz.

Multi-Frequency Adaptive Meshing 1-10
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* Auto HPC is defined and 12 cores are used for the simulation.

Driven Sclution Setup ﬁ

General lOptinns ] Advanced ] Hybrid ] Expression Cache ] Dervatives ] Defaults ]

Setup Mame |I"-'1uhiFreq

[v Enabled [ Solve Parts Only

Adaptive Solutions

Solution Frequency: {” Single {* Multi-Frequendes " Broadband

Frequency Lnit Max. Delta Add |
) GHz 0.02
10 GHz 0.02

Maximurn Murnber of Passes | 15

lUse Defaults |

HPC and Analysis Options... ‘

ok | Cancel |

The return loss after solving the Multi-Frequency analysis setup is shown below.

Multi-Frequency Adaptive Meshing 1-11
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Comparison of Sinuous Antenna Results

The antenna is solved at a center frequency of 8.5 GHz with 12 cores and auto HPC.

Comparison of the return loss results for the three solution frequency setups are shown below.

Multi-Frequency Adaptive Meshing 1-12
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This example demonstrates the power of using broadband adaptive meshing as it produces very
accurate results without the need for you to specify specific adaptive frequencies. Additionally,
the performance of Broadband adapt was similar with Multi-Frequencies partly because the six

adapted frequencies were solved in parallel and reused, rather than re-solving those fre-
quencies, for the interpolating sweep.
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